Lawn Care Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a P20 TruCut that runs but after I turn it off and try to re-start it, it doesn't want to run. I have to wait for like 30 minutes before I can restart it.
Does anyone know why this is? Is there some type of "thermal switch" that cuts off the mower from restarting right away?

Also, does anyone know what those green and yellow wires going into the motor is for? And what the black wire going into the motor is for?
Could these be sensors that is preventing the mower from restarting right away?
 

Attachments

·
Premium Member
Joined
·
534 Posts
The green and yellow wires are for the low oil sensor which is mounted in the engine block, low oil and the unit shuts off. You could check the oil level first and see if it’s low, that would be a consistent non start problem though. Sounds like another intermittent part in play. You could have a coil going bad on the flywheel, bad spark plug wire, bad spark plug.

troubleshooting intermittent problems can be rough. One good troubleshooting test for spark is to simply pull the plug from the motor, put the plug wire boot back on the plug, let the threaded part of the plug rest on a metal portion of the mower, pull the rope and check for spark when the machine is acting up. Good luck with your problem, sounds like an ignition issue to me.
 

·
Premium Member
Joined
·
534 Posts
That is gas on the plug from being sprayed into the head from the carb. Four parts of the combustion process, spray, spark, bang and exhaust. In that order.If Any of those are missing or the timing of them is off and the motor won’t run or start.
 
1 - 4 of 4 Posts
Top